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Statement 

1. Implementation. The softwares of the CUCKOO Workgroup are implemented in 
JAVA (J2SE). Usually, both of online service and local stand-alone packages will be 
provided.  
2. Availability. Our softwares are freely available for academic researches. For 
non-profit users, you can copy, distribute and use the softwares for your scientific 
studies. Our softwares are not free for commercial usage.  
3. GPS. Previously, we used the GPS to denote our Group-based Phosphorylation 
Scoring algorithm. Currently, we are developing an integrated computational platform 
for post-translational modifications (PTMs) of proteins. We re-denote the GPS as 
Group-based Prediction Systems. This software is an indispensable part of GPS.  
4. Usage. Our softwares are designed in an easy-to-use manner. Also, we invite you 
to read the manual before using the softwares.  
5. Updation. Our softwares will be updated routinely based on users’ suggestions and 
advices. Thus, your feedback is greatly important for our future updation. Please do 
not hesitate to contact with us if you have any concerns.  
6. Citation. Usually, the latest published articles will be shown on the software 
websites. We wish you could cite the article if the software has been helpful for your 
work.  
7. Acknowledgements. The work of CUCKOO Workgroup is supported by grants 
from Chinese 973 project (2002CB713700, 2006CBOF0503, and 2006CB933300), 
Chinese Academy of Sciences (KSCX1-YW-R65, KSCX2-YW-21, and 
KJCX2-YW-M02), Chinese Natural Science Foundation (39925018, 30270293, 
90508002, 30700138) and National Institutes of Health (DK56292).  
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Introduction 

Schematic diagram of protein domain structures with functional motifs/sites is an 
important part in a large proportion of scientific articles which are focused on 
molecular and cellular researches. Diagram of protein domain/motif structures in an 
attractive, concise and precise manner is greatly helpful for a broad readership to 
grasp the old and novel functions of proteins rapidly.   
 
Usually, experimentalists could draw a protein domain graph with Microsoft 
PowerPoint, PhotoShop or other graphic softwares. However, the scale of a functional 
domain is often approximately decided by eyes. Thus, diagram of protein domain 
structures in exact proportions is almost unavailable. Also, the position of a specific 
motif or functional sites (e.g., a phosphorylation site) could be only roughly pointed. 
In this regard, preparation of an exquisite figure is quite time-consuming by 
hand-drawing. On the other hand, the protein domain graphs could be automatically 
generated by a dozen of computational programs. For example, the Pfam, SMART, 
PROSITE, InterPro and other related databases or online tools could predict out the 
functional domains organization of a given protein sequence, and generate the result 
into a figure. However, these tools couldn’t help experimentalists to design their own 
graphs. Taken together, a software to generate user-defined protein domain graphs 
will be a great help for experimentalists to prepare their manuscripts.   
 
Now, we present a software of DOG (Domain Graph, version 1.0) for experimentalists, 
to prepare publication-quality figures of protein domain structures. The scale of a 
protein domain and the position of a functional motif/site will be precisely calculated. 
The DOG 1.0 was written in JAVA 1.5 (J2SE 5.0) and packed with Install4j 4.0.8. 
Thus, the DOG 1.0 could be easily installed on a computer. Then we developed 
several packages to support three major Operating Systems (OS), including Windows, 
Unix/Linux and Mac. The Windows XP, Fedora Core 6 OS (Linux), Apple Mac OS X 
10.4 (Tiger) and 10.5 (Leopard) were chosen to test the stability of DOG1.0 software. 
For Windows and Linux systems, a Java Runtime Environment 6 (JRE) package of 
Sun Microsystems was also included.  
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Download & Installation 

The DOG 1.0 software was implemented in JAVA 1.5 (J2SE 5.0), and could be 
installed on three major Operating Systems (OS), including Windows, Linux/Unix or 
Mac OS X systems. The local stand-alone packages of DOG 1.0 can be freely 
available at http://dog.biocuckoo.org/software.php. We recommend that users could 
download the latest release. 
 
Please choose the proper package to download. After downloading, please 
double-click on the software package to begin installation, following the user prompts 
through the installation. And snapshots of the setup program for windows are shown 
below: 
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Finally, please click on the Finish button to complete the setup program. 
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The DOG work environment 

When you open DOG for the first time, DOG activates the work environment, 
including the Canvas, Console panel, Component List and Menus. Also, there are 35 
examples included in the software. Randomly, the schematic diagram of human 
ZAP70 domain structures is shown below.  

 

Canvas 

Display the graph of the current project. 
You can use the keyboard UP/DOWN or mouse Wheel Up/Wheel Down to zoom 
in/out the graph. You can also use the Right-Click popup menu to adjust the graph. 
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Console 

This panel contains four option buttons for drawing protein domain structures. 
1. Protein button: Define the basic properties of the current protein.  
2. Domain button: Add a functional domain to the current protein. 
3. Site button: Add short motif (usually<15aa) or functional site to the current 

protein.  
4. Note button: Add name of the current protein or some other comments. 

Component List 

List all the components of the current project, including protein, domain, site and note. 
Different components could be marked in different colors and major properties. 
 
You can use the Right-Click popup menu to edit, delete or insert a new component 
before the selected component.  

 
You can also double click a component to edit it. 
 

Menus 

File menu 

 
 
New project 
Open a new and untitled DOG project. 
 
Open project 
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Display a dialog box allowing you to open an existing DOG project file and display 
the contents in a new canvas. 
 
Save 
Save the contents of the current project in XML format as a file in the current 
directory or folder on the disk. If this is the first time that you are saving the file, you 
must enter a file name. If the file has been saved before, the existing file name is used. 
 
Caution: The Save command will overwrite any file with the same name that is in the 
same directory or folder! If you do not want to do this, choose File -> Save As and 
give the file a different name. 
 
Save As… 
Display a dialog box allowing you to save the contents of the current project in XML 
format as a file, with a file name that you provide.  
 
Export Image 
Export image in either PNG or JPEG format to a file on the disk. 
 
Exit 
Close the current project and exits the current DOG session. A dialog asks if you want 
to save or abandon the changes, or cancel the command. 

Edit Menu 

 
 
Add Domain 
Add a functional domain to the current protein. 
 
Add Site 
Add short motif (usually<15aa) or functional site to the current protein. 
 
Add Note 
Add name of the current protein or some other comments. 
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Tools menu 

 
 
Demo 
We randomly re-drew domain graphs for 35 distinct proteins from five journals, 
including Cell, Nature Cell Biology (NCB), The Journal of Cell Biology (JCB), 
Molecular Biology of the Cell (MBC) and Molecular and Cellular Biology (MCB). 
These instances could be browsed in online or software demos.  
 
 

Online Demo 
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Software Demo 

 

 
Image Format 
 

 
 

With this tool, you can convert image in JPG, PNG or GIF format to TIFF format with 
300-1200dpi. 
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Illustration of Protein Domain Structures 

New Protein 

When you click the Protein button or choose File -> New Project, a new protein feature 
dialog box will appear as shown below: 

 
 
The right area of the property dialog box contains the following settings for the protein: 
1. Sequence length of the protein 
2. Display height of the protein 
3. Display color of the protein 
4. Font size of the position number 
Note: For convenience, the “Preview” panel shows the effect of current figure.  

Add Domain 

When you click the Domain button or choose Edit -> Add Domain, a domain property 
dialog box will appear as shown below: 
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The right area of the property dialog box contains the following settings for the domain: 
1. Start position of the domain. 
2. End position of the domain. 
3. Name of the domain. 
4. Display color of the domain. 
5. Font size of the text 
 
Note: 

You can use the position direction combo box to set the start and end 
position texts display above or under the domain or not display at all. 
 
 
Down: 

    
  
 

Up:   
 
 

 
Hide:  

 
 

Use the name Direction combo box to set the name of domain display above, 
under or inside the domain or not display at all. 
 
 
 

Center: 
 

 
 

Up: 
 
 
 

Down: 
 
 
 

Hide: 
 

12 



DOG Manual 

Add Site 

When you click the Site button or choose Edit -> Add Site, a site property dialog box 
will appear as shown below: 
 

 
 
The right area of the property dialog box contains the following settings for the site: 
1. Positions of the site. 
2. Text of the site 
3. Font size of the text. 
4. Display Color of the text. 
5. Display height of the site text. 
 
If you have more than one position to draw, please delimit the positions with commas. 
There are three different display ways based on the number of the positions. 
 

 
 

One position  
 
 
 
 

Tow positions  
 
 
 
 

Three or more positions  
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You can use the Direction combo box to set the site text display in six 
different directions. 
 
 
 

 
 

 
Top:   
 
 
 
 
 
Bottom: 
 
 
 
 
 
TopRight: 
 
 
 
 
 
TopLeft: 
 
 
 
 
 
BottomRight: 
 
 
 
 
 
BottomLeft: 
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Use the Line combo box to set the line display with or without position 
text or not display at all. 
 
 
 

 
 

Show  
 
 
 
 

              Position 
               
 
 
 

Hide 
 
 

Add Note 

When you click the Note button or choose Edit -> Add Note, a note property dialog box 
will appear as shown below: 
 

 
 
The right area of the property dialog box contains the following settings for the note: 
1. Text of the note. 
2. Font size of the text. 
3. Color of the text. 
4. Font style of the text. 
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You can use the Direction combo box to set the note text display in four 
different directions.  
 
 

Up 
 

 
 
  

Left  
 
 
 
 

 
Right  
 
 
 
 

 
Down  

 

Mouse-clicking  

For convenience, we add a new function of mouse-clicking. Here, we used hAGO2 
(1.xml in demo) as an instance to depict the usage.  
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For further editing of protein parameters (eg, color, length, and font size, etc), you can 
directly double-click the left button on the marker region below: 
 

 
 
Then the protein feature dialog box will appear as shown below: 
 

 
 
If you want to edit a protein domain, please double-click the left button on the marker 
region below: 
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Then the PAZ domain property dialog box will appear as shown below: 

 

 
 
Also, you can use similar method to edit Site or Note information.  
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Release Note 

1. Feb. 2nd, 2008, the final packages of online demo and local stand-alone softwares of 
DOG 1.0 are released.  

2. Mar. 25th, 2008, a bug on opening project was found and fixed.  
3. Apr. 19th, 2008, Dr. Fernan Aguero (San Martin, Argentina), had contacted and 

reminded us that our software could not be installed or worked under Linux/Unix 
systems. We have re-complied the package of DOG 1.0 for Linux/Unix to fix the bug. 

4. May 18th, 2008, a new function of “Mouse-clicking” was added in the software. And 
the figure format was extended to be exported in JPEG format.  

5. Aug. 28th, 2008, rebuild the GUI with NetBeans 6.1. 
6. Jan. 3rd, 2009, DOG version 1.0.3 was released. We fixed a bug that cannot create a 

new file under Mac OS X. The Acknowledgement list and contact information were 
added into the new version. 

7. Jan. 19th, 2009 ， DOG web server was moved to new website 
(http://dog.biocuckoo.org) and a new GPS logo was put into use. 

8. Apr. 7th, 2009, DOG version 1.0.4 was released. The DOG image can be exported in 
TIFF format with 300 or 600dpi. Image Format was added in Tools menu. 

9. Jun. 10th, 2009, DOG version 1.0.5 was released. Express the domain length with 
relative length instead of absolute length. 
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